admin@moneyyes.info      +

Statement on NPM Package Vulnerability in v5.0.2-5.1.0 of Copay Wallets

Statement on NPM Package Vulnerability in v5.0.2-5.1.0 of Copay Wallets
By: bitpay.com Posted On: November 27, 2018 View: 2

Statement on NPM Package Vulnerability in v5.0.2-5.1.0 of Copay Wallets

We have learned from a Copay GitHub issue report that a third-party NodeJS package used by the Copay and BitPay apps had been modified to load malicious code which could be used to capture users' private keys. Currently we have only confirmed that the malicious code was deployed on versions 5.0.2 through 5.1.0 of our Copay and BitPay apps. However, the BitPay app was not vulnerable to the malicious code. We are still investigating whether this code vulnerability was ever exploited against Copay users.

Our team is continuing to investigate this issue and the extent of the vulnerability. In the meantime, if you are using any Copay version from 5.0.2 to 5.1.0, you should not run or open the app. A security update version (5.2.0) has been released and will be available for all Copay and BitPay wallet users in the app stores momentarily.

Users should assume that private keys on affected wallets may have been compromised, so they should move funds to new wallets (v5.2.0) immediately. Users should not attempt to move funds to new wallets by importing affected wallets' twelve word backup phrases (which correspond to potentially compromised private keys). Users should first update their affected wallets (5.0.2-5.1.0) and then send all funds from affected wallets to a brand new wallet on version 5.2.0, using the Send Max feature to initiate transactions of all funds.

Let's block ads! (Why?)

Read this on bitpay.com Ad1
  Contact
 Payment systems online

67/2

Tel : +
Mail : admin@moneyyes.info
Business Hours : 24

  Follow Us
Site Map
Show site map
  About

There are plenty of online payment systems out there that you can use to conduct e-commerce activities. Top online payment systems for accepting payments on the Web.